Regional Reachability Issues

Incident Report for linqi Cloud

Resolved

This incident has been resolved.
Posted May 05, 2026 - 22:18 CEST

Monitoring

Following our investigation, we have identified that the current access issues are caused by a widespread, global DNS outage affecting multiple services and providers worldwide.

Because this is an external infrastructure issue, resolving it is unfortunately beyond our direct control. We are closely monitoring the situation and upstream providers. We will update this page as soon as the global DNS services are restored and our website and helpdesk are fully accessible again. Thank you for your continued patience.
Posted May 05, 2026 - 22:15 CEST

Investigating

We are currently experiencing issues with DNS resolution originating from specific countries. As a result, some users in these regions may experience intermittent difficulties accessing our website and helpdesk.

Our engineering team is actively investigating the root cause of this issue. We will provide another update as soon as we have more information. Thank you for your patience.
Posted May 05, 2026 - 22:08 CEST